i

Screen

BEEE

Bazics

B

Dirawing

78

Caolor




= Quick Look

e What is a Cursor?

e What is a Bitmap?

e What is an Icon?

e What is an .RC Script?

e Access Keys
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Steps to Creating an Image

File Types
Creating a File

Opening a File

Saving or Renaming a File

Creating a New Image in a File

Selecting an Image

Deleting an Image in a File

Restoring an Image to the Previous Save
Copying an Image to Another Application

Defining Images in the IMAGEDIT.INI File
Exiting the Image Editor




L Drawing

¢ Tips on Designing Images
e Drawing Free-Form Lines
¢ Drawing Straight Lines

e Drawing Ellipses

¢ Drawing Rectangles

¢ Drawing Shapes

¢ Changing the Brush Width
¢ Toggling the Grid

¢ Creating a Cursor Hot Spot
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% Color

¢ Tips on Using Color

e Using Opague Colors

¢ Using Screen Color

¢ Using Inverse Color

e Setting Colors to the Mouse Buttons
¢ Viewing Different Screen Colors

e Editing Colors on the Color Palette
e Saving or Loading a Color Palette




..E.. Screen Features

e Key to the File Menu

¢ Key to the Edit Menu

e Key to the Options Menu
¢ Key to the Help Menu

e Key to the Properties Bar
e Key to the Toolbox

e Key to the View Window

¢ Key to the Color Palette







EEM File Types

With the Image Editor, you can create files for cursor, bitmap, and icon resources. Both
cursor (.CUR) and icon (.ICO) files can have multiple images. Multiple images are a set of
modified images based on a single image. Each image in the set matches a display
device, such as a VGA or monochrome display.

* Descriptions:
Images Described
Cursors and Icons

Bitmaps
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In an icon or a cursor, each pixel description can consist of either an opaque color from a
color palette, a screen color, or an inverse color.

If the pixel has an opaque color, it always takes that fixed color. In a cursor, black and
white are the only opaque color choices for most devices. Screen colors and inverse colors
are masks. They indicate either that the pixel should take the screen color of the display
or that it should take the inverse of the screen color. If a pixel takes the screen color, that
portion of the icon or cursor appears transparent. If a pixel takes the inverse color, that
portion of the icon or cursor appears to be highlighted. These two color values change
automatically as the screen color changes. In a cursor, these two color values also change
automatically as the cursor passes over different portions of the screen.



In a bitmap, each pixel displays an opaque color that you choose from the color palette.

A bitmap type always displays the same colors no matter what screen color appears on
the display device.



All the images that you can create with the Image Editor are bitmaps. A bitmap describes
the color characteristics for every pixel contained in an image.

In a monochrome (two-color) bitmap, each pixel is represented by one bit, with a value of

1 for white and 0 for black. A color bitmap uses multiple bits to define the color for a
single pixel.



Icons represent files or windows when they are minimized. You can place the mouse

pointer on an icon, and take some action involving that object. For example, you could:

¢ Apay tne the icon to another screen location

e Cause an action by moving the icon from one window to another---such as moving files
in the File Manager.

¢ Expand a window by double-clicking the icon



EEM Creating a File
When creating a file, you must choose either a bitmap, icon, or cursor file type. Each file
type has a different purpose in your application. You can create cursor (.CUR) and icon
(.1CO) files with multiple images. Multiple images can match displays---for example, VGA,
EGA, CGA, and monochrome monitors---with the proper image. Windows selects the
correct resource to display.

= To create a new file:
1.From the File menu, choose New. The Resource Type dialog box appears.
2.Select either Cursor, Bitmap, or Icon.

3.Choose OK.

After you select a resource type (image), a dialog box appears in which you can set values
for the image.

* Values for Bitmaps:
Widt Heigh Colors
h t

® Values for Cursors and lcons:

Target
Device
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A pixel dimension with the maximum value of 256



A pixel dimension with the maximum value of 256



By default, the Image Editor uses values matching the display on which it is running. You
can change the selection.

Use the 2-color option for monochrome displays. Use the 16-color option for all other
displays.

The color palette shows the colors available by the selection. Dithered colors also appear
in the palette. The dithered colors are based on the available colors. You can use dithered
colors to fill but not to draw.



The type of display device on which the image will appear.



EEM Setting Values for Bitmaps

Values for bitmaps:

Widt Heigh Colors
h t

Related Topics



B0 Opening a File
The Open command on the File menu loads an existing .CUR, .BMP, or .ICO file.

= To open a file:
1. From the File menu, choose Open.

2. Choose a drive from the Drives drop-down list box. The default drive is the current
drive.

3. From the Directories list box, select the directory in which the file is stored .

4. Determine if the default extension in the File Name text box is the correct extension
for the file type---the default is the extension of the previously opened file. If not,
choose a file type in the List Files of Type box or type in an extension in the File Name
text box, and then press ENTER. Files with the chosen extension are displayed in the File
Name box.

5. Double-click a filename, or click a filename and choose OK.

* For .CUR and .ICO files only:
After you choose to open a .CUR or .ICO file, a dialog box displays the image or images in
the file. Since you can create more than one image in a .CUR or .ICO file, this dialog box
allows you to open the image of your choice. The images are listed by device type---for
example, 4-Plane 32x32 Pixels.

Related Topics

Shartcuts



Extension File Type

.CUR Cursor files

.BMP Bitmap files

ICO Icon files

* All files in a directory

Open CTRL+0



EEM Saving or Renaming a File
You can use the Save command on the File menu to save a new file. You can also use the
Save As command to save a new file or rename an existing file. A file is saved as either a
.CUR, .BMP, or .ICO file.

* To save a new file:
1. From the File menu, choose Save.

The first time a files is saved, the Save File dialog box is displayed in order for the file to
be given a name. After the first save, the dialog box is no longer necessary.

2. From the Directories list box, select the directory in which you want to store the file.
The default directory is the current directory.

3. Type a filename in the File Name text box, then choose OK.

The default extension given to a file is the extension for the file type you opened. You can
change the extension as desired.

When you save a file that can have multiple images---.CUR and .ICO files---all images are
saved.

* To save a new file or rename an existing file:
1. From the File menu, choose Save As.

2. From the Directories list box, select the directory in which you want to store the file.
The default directory is the current directory.

3. Type a filename in the File Name text box, then choose OK.

+ This procedure is useful for maintaining revised copies of a file while keeping the original
unchanged.
Related Topics

Shortcuts



Save CTRL+S



The file extension for cursor resources.



The file extension for bitmap resources.



The file extension for icon resources.



E]
EEM Creating a New Image in a File

You can create multiple icon and cursor images for various display devices. For instance,
you might create a cursor file with both a 16-color image and a monochrome image.
Windows determines the display that your application is running on and selects the proper
resource for it.

= To create a cursor or icon for a specific display type:
1. From the File menu, choose New. The Resource Type dialog appears.

2. Select Icon or Cursor, then choose OK. A dialog box specific to cursor or icon files
appears.

3. In the Target Device list box, choose a device type. The default is the display type for
your monitor.

Having created a .CUR or .ICO file for one display type, you can add images for other
display types to it. This allows you to prepare images adapted to different possible pixel
dimensions and color capabilities of various display devices.

= To create a new image in a file:
1.From the Edit menu, choose Copy. This copies the existing image to the Clipboard.

2.From the Edit menu, choose New Image. A dialog box specific to cursor or icon files
appears.

3.Select the image type from the list, then choose OK.
4. From the Edit menu, choose Paste.

The image is now copied into the drawing area for editing.

Felated Topicz
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EEM Selecting an Image

When you create, open, or edit a .ICO or .CUR file, the Image Editor allows you to select an
image type or an existing image in a file.

* To create a cursor or icon type for a specific display:
1.From the File menu, choose New. The Resource Type dialog appears.

2.Select Icon or Cursor, then choose OK. A dialog box specific to cursor or icon files
appears.

3.In the Target Device list box, choose a device type. The default is the display type for
your monitor.

* To select a cursor or icon in a file you are opening:
1.From the File menu, choose Open. The Open File dialog appears.

2.0pen a .ICO or .CUR file. A dialog box specific to cursor or icon files appears. The dialog
box lists the images in the file.

3.Select an image type from the list box.
4.Choose OK.

* To select an image in an open file:
1.From the Edit menu, choose Select Image. A dialog box specific to cursors or icons
appears.

2.Select an image type from the list box.
3.Choose OK.

Related Topics
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EEM Deleting an Image in a File
You can delete the current image by choosing the Delete command on the Edit menu. To
delete an undisplayed image in a file, you must first select it.

* To select and then delete an image:
1.From the Edit menu, choose Select Image. A dialog box specific to cursors or icons
appears.

2.Select an image type from the list box.
3.Choose OK. The image is displayed in the drawing area.
4. From the Edit menu, choose Delete Image.

Related Topics

Sharteuts



Clear CTRL+L
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EEM Restoring an Image to the Previous Save
You can undo all of your editing changes to an image since the image was last saved or
loaded to the drawing area.

* To restore an image:
¢ From the Edit menu, choose Restore.

The Undo command undoes the last change to an image. The Restore command returns
an image to the state it was in when it was loaded or last saved.

Related Topics



EEE Copying an Image to Another Application

You can copy images from other drawing applications to the Image Editor. The image does
not need the same pixel dimensions as the drawing area. You can shrink, expand, or clip
the image in the Image Editor as you paste the image. You can also copy images created
in the Image Editor from the Clipboard to other applications.

* To copy an image from another application:
1.Select an image in the other application. Use the Cut or Copy command in the other
application to copy the image to the Clipboard. All standard Windows applications have
Cut and Copy commands.

2.Create a file or a new image in the Image Editor, then choose the type of image and its
properties.

3.0pen the Edit menu and choose Paste. A dialog box appears if the image you are
pasting does not have the exact pixel dimensions as the drawing area. You have several
options in the dialog box:

¢ Choose Stretch/shrink clipboard bitmap if the image is larger than the drawing area and
you want to shrink it to appear in the drawing area.

¢ Choose Stretch/shrink clipboard bitmap if the image is smaller than the drawing area
and you want to expand it to fill the entire drawing area.

¢ Choose Clip clipboard bitmap if the image is either larger or smaller than drawing area.
This option pastes only the upper left rows and columns of pixels corresponding exactly
to those rows and columns in the drawing area.

If the image is larger than the drawing area, those parts of the image that would appear
beyond the lower right corner of the drawing area disappear.

If the image is smaller than the drawing area, those parts of the drawing area beyond
the lower right-hand corner of the image remain unchanged.

* To copy an image to another application:
1.Select the pick rectangle tool in the Toolbox of the Image Editor.

2.Select the image you want to copy from the drawing area.
3.From the Edit menu of the Image Editor, choose Copy.

4. Switch to the other application, then use the Paste command in the other application
to paste the image from the Clipboard.

Related Topics

Shartcuts



Copy CTRL+C

Paste CTRL4+V



E]
EEM Exiting the Image Editor

The Exit command on the File menu closes the Image Editor.
If there is an unsaved file open, you will be asked whether it should be saved.

Related Topics

Shortcuts



Exit ALT+F4
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EEM Steps to Creating an Image

Before creating a new image, you first need to design it. The image should be appropriate
for the application and suited to the display types on which the application runs.

* To create an image, follow these general steps:
1.Design an appropriate graphical representation.

2.0pen a file.

3.Select an image type, its size, and its display attributes.

4 .Select colors from the palette.

5.Select drawing tools.

6.Draw the image in the drawing area with the selected tools.

Related Topics



You may want to look at these topics before you design an image:
e Tips on Using Color
¢ Tips on Designing Images




B0 Defining Images in the IMAGEDIT.INI File

By default, the Image Editor allows you to edit images for common display devices such
as VGA or monochrome. You can create definitions of image types for other display
devices. The Image Editor uses the IMAGEDIT.INI file to keep the image definitions for
icons and cursors used on display devices other than the default devices. These
definitions will appear as options in a list of target devices in a New Image dialog box.

IMAGEDIT.INI is an ASCIl, comma-delimited file that you can edit. It contains sections with
information about your preferences. You create separate sections for the definitions of
devices associated with icons and cursors. Each string in the section defines a display
device. Each string is terminated by a carriage return and contains the following four
fields:

¢ Name of the display device. The nhame can contain up to 12 uppercase and lowercase
letters.

Number of colors in the icon or cursor image.
Horizontal size of a cursor or icon in pixels.
Vertical size of a cursor or icon in pixels.

In addition to information about icon and cursor images, IMAGEDIT.INI can include
comments. Indicate a comment by placing a semicolon (;) at the beginning of the
comment line.

For example, you could add the following IMAGEDIT.INI sections to specify information for
a Super-VGA device:

[ImagEdit.Icon]
SuperVGA=16, 64, 64

[ImagEdit.Cursor]
SuperVGA=16, 32,32

These two sections define a 16-color icon with a size of 64 by 64 pixels, and a 16-color
cursor, but with a size of 32 by 32 pixels.

The Image Editor displays this information when you choose characteristics for a new
image, and it displays the characteristics for the image type after you load the image into
the editor.

Related Topics






e
U Tips on Using Color

When possible, you should follow these general guidelines to create the most effective
images:

¢ Always begin designing images in black and white. If the image looks good in black and
white, it will look even better in color.

¢ Use three-dimensional effects to emphasize function. Changes in three-dimensional
appearance emphasize changes in function, as when a button is "pressed." Use black,
white, light gray, and dark gray to create three-dimensional shading effects.

e Examine your designs on a variety of backgrounds because they will not always appear
on white or gray, for instance. It is especially important to check cursors against black
and white backgrounds, because black and white are the only opaque colors available
for the creation of cursors on most devices. To ensure that cursors are always visible,
outline them in the opposing color, or use inverse color for the cursor shape.

¢ About 10% of the adult male population has some form of color confusion, with a small
fraction of that being true red/green color blindness. Because of this reason, use color
as a redundant cue, and don't rely on color alone to indicate a property or function.

¢ Use color to direct attention and to show relatedness and grouping.

¢ Avoid blue for small or thin graphic elements or small text, because the focusing center
of the eye (the fovea) has very few light receptors for blue (blue cones). Blue works well
as a background, however.

¢ Avoid large areas of bright colors because they tend to leave afterimages of the
opponent color on the retina.

Felated Topics



e
.| Using Opaque Colors

Opaque colors in the Image Editor always take the same fixed value in the image when it
is displayed in the application. Values of red, green, and blue are opaque colors.

The rows of boxes at the right of the Color Palette window are opaque colors.

You can use opaque colors in bitmaps, icons, and cursors.

* To draw an oval and color it:
1.Select an opaque color in the color palette.

If you are creating a cursor, you can select only black or white.
2.Select the circle tool from the Toolbox.
3.Drag the mouse on drawing area.

+ Because black and white are the only opaque colors available for the creation of cursors
on most devices, it is important to check cursors against black screens and against white
screens. To ensure that cursors are always visible, outline them in the opposing color or use
the inverse color for the entire cursor shape.

Felated Topicz
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L. Using Screen Color
Areas of the image painted with screen color in the Image Editor always take the color of
the screen when the image is displayed in the application. These areas appear
transparent in the application. All pixels in the drawing area use screen color by default
when you create a new image.

While you are editing images, you can choose which color the screen should display. The
chosen color appears anywhere you use screen color in the drawing area. It also appears
around the perimeter of the View window. In an application, the screen color depends on
choices the application's user has made.

The screen color is shown in the top box between the mouse button boxes and the opaque
colors in the Color Palette.

You can use screen color only in icons and cursors.

* To create an image containing an opaque square with a transparent circle in its center:
1.Select an opaque color in the palette with the left mouse button.

If you are creating a cursor, you can select only black or white.
2.From the Toolbox, select the rectangle tool.
3.Drag the mouse on the drawing area to create the square.
4.From the palette, select the screen color.

The screen color is the top box between the mouse button boxes and the opaque colors
on the Color Palette window.

5.From the toolbox, select the circle tool.
6.Drag the mouse on the square to create the circle.
The circle inside the square always takes whatever color you now choose for the screen.

+ Choose various screen or inverse colors to see how your image appears on different

backgrounds. Your image will not always appear on white or gray, for instance.
Felated Topics
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L. Using Inverse Color
Areas of the image painted with inverse color in the Image Editor always take the inverse
of the screen color when the image is displayed in the application. These areas appear
highlighted in the application.

While you are editing images, you can choose which inverse color to display. Choosing an
inverse color also sets the screen color. In an application, the inverse color depends on
choices the application's user has made.

The inverse color is shown in the bottom box between the mouse button boxes and the
opaque colors on the Color Palette window.

You can use screen color only in icons and cursors.

* To create an image containing an opaque circle with a highlighted center:
1.Select an opague color in the palette with the left mouse button.

If you are creating a cursor, you can select only black or white.
2.From the Toolbox, select the circle toal.
3.Drag the mouse on the drawing area to create the circle.
5.From the palette, select the inverse color.

The inverse color is the bottom box between the mouse button boxes and the opaque
colors on the Color Palette window.

6.From the toolbox, select the flood fill tool.
7.Move the flood fill tool into the center of the circle and click.

+ Choose various screen or inverse colors to see how your image appears on different
backgrounds. Your image will not always appear on white or gray, for instance.
*



+ Setting Colors to the Mouse Buttons
You can associate colors with both the left and the right mouse buttons. The chosen color
appears on the drawing area when you manipulate a drawing tool with that button. The
boxes at the far left of the Color Palette window show the colors associated with the left
and right mouse buttons.

If you are creating a bitmap, you can choose only opague colors. The opaque colors are
shown in the rows at the right of the Color Palette window.

If you are creating an icon or a cursor, you can associate either the screen color or the
inverse color with a mouse button. When you are creating an icon or a cursor, the screen
and inverse colors are shown on the Color Palette between the mouse button boxes and
the opaque colors. The top box shows the screen color; the bottom box shows the inverse
color.

The drawing tool that you are currently using creates shapes with the color associated
with the mouse button that you hold down while using the tool. If it is a dithered color, the
filled rectangle, filled ellipse and flood fill tools use the actual color from the palette, as
shown in the bottom part of the mouse button box. The other tools use the color shown in
the top part of the mouse box, which is the solid color nearest to the chosen dithered
color.

You choose opaque, inverse and screen colors in exactly the same manner.

+ To associate colors with the mouse buttons:
1.Use the left mouse button to select the color that you want associated with that mouse
button.

2.Use the right mouse button to select the color that you want associated with that
mouse button.

+ Avoid blue for small or thin graphic elements or small text. Avoid large areas of bright
colors because they tend to leave afterimages of the opponent color on the retina.
*



+ Viewing Different Screen Colors
You can either choose a single color for the screen color in the View window using the
mouse, or you can cycle through all the possible solid screen colors on the palette one
after another in the View window using the keyboard. With these methods, you can see
what your images look like on different backgrounds.

+ To choose a single color for the screen color:
1.Select the desired color on the color palette with the left mouse button.

2.Click the View window.

+ To cycle through the colors:
1.Click the View window.

2.Press the PLUS (+) key on the numeric keypad to display the next color, or press the
MINUS (-) key to display the previous color.

Each subsequent press on the PLUS or MINUS key displays another color.



+ Editing Colors on the Color Palette
You can edit the colors on the Image Editor color palette one color at a time. You can edit
the opaque colors for all image types, and additionally, you can edit the screen color or
inverse color for icon and cursor images.

+ To edit a color:
¢ Select the color on the palette, and then choose the Edit button on the Color Palette
window.

--Or__
¢ Double-click the color on the palette.

Either method displays the Color dialog box.

+ To specify a color from the basic colors in the Color dialog box:
1.Select a color from the basic colors.

2.Choose OK.

The selected color now appears in the Image Editor palette in place of the default color.
You can also define custom colors different from the basic colors in the Color dialog box.

+ To define a custom color in the Color dialog box:
1.In the Color dialog box, choose the Define Custom Colors button.

2.In the Custom Colors boxes, select a box.
3.Define a color using one of the following methods:
¢ Type the RGB values in the RGB entry boxes.
¢ Type the HLS values in the HLS entry boxes.

¢ Move the crosshair on the color spectrum control to the desired color and then move
the luminosity indicator on the right edge of the dialog box to the desired value.

With all methods, the color that you're defining appears in the Color/Solid box.
4.Choose the Add to Custom Colors button.

The color appears in the selected Custom Colors box.
5.Choose OK.

The newly defined color now replaces the color that you originally selected in the Image
Editor color palette.



+ Saving or Loading a Color Palette
You can save a color palette in a palette file (.PAL). You can load the colors from a palette
file into the Image Editor's color palette.

+ To save a palette:
1.From the File menu, choose Save Colors.

2.Enter a name for the file in the File Name text box.

Palette files have the default filename extension .PAL.

If necessary, select the drive and directory from the displayed list boxes.
3.Choose OK.

+ To load a palette:
1.From the File menu, choose Load Colors.

2.Select a file from the File Name text box.
Palette files have the default filename extension .PAL.

If necessary, select the drive and directory from the displayed list boxes to find the
desired palette file.

3.Choose OK.

+ To restore the default palette:
¢ You can restore the default palette by choosing Restore Default Colors from the File
menu.



Opaque color is always the same color, regardless of the screen color.
The rows of indicators on the right side of the Color Palette window are all opaque colors.



Screen color always takes the value of the screen and appears transparent in images.

The screen color shows in the top indicator between the mouse button indicators and the
opaque color indicators on the Color Palette (for icons and cursors only).

For the initial value of this color, the Image Editor uses the solid color nearest to the color
set for the Windows background.



Inverse color always takes the inverse value of the screen color.

The inverse color shows in the bottom indicator between the mouse button indicators and
the opaque color indicators on the Color Palette (for icons and cursors only).

For the initial value of this color, the Image Editor uses the inverse of the solid color
nearest to the color set for the Windows background.






+ Tips on Designing Images
Follow these general guidelines to create the most effective images:

e Always begin designing images in black and white. If the image looks good in black and
white, it will look even better in color.

¢ Use three-dimensional effects to emphasize function. Changes in three-dimensional
appearance emphasize changes in function, as when a button is "pressed." Use black,
white, light gray, and dark gray to create three-dimensional shading effects.

e Examine your designs on a variety of backgrounds, because they will not always appear
on white or gray, for instance.

It is especially important to check cursors on black screens and on white screens,
because black and white are the only opaque colors available for the creation of
cursors. To ensure that cursors are always visible, outline them in the opposing color, or
use inverse color for the cursor shape.

e Create a similar style for icons which appear together, in order to minimize distraction.



+ Drawing Free-Form Lines
Use the brush tool or pencil tool to draw a continuously connected curve or free-form line
segment. The pencil tool draws in a single width---one pixel---and the brush tools draws in
four possible widths---two, three, four, or five pixels. Both draw in the current color.

+ To draw a free-form line:
1.From the color palette, select a color for one of the mouse buttons.

2.From the Toolbox, select the brush or pencil tool.
3. Drag the mouse on the drawing area, using the button with the assigned color.

+ To change the line width of the brush tool:
1.From the Options menu, choose Brush Size.

2.Select a brush width.



+ Drawing Straight Lines
Use the line tool to draw a straight line. The line tool draws in a single width---one pixel.

+ To draw a straight line:
1.From the color palette, select a color for one of the mouse buttons.

2.From the Toolbox, select the line tool.
3.0n the drawing area, drag the mouse, using the button with the assigned color.
4 .Release the mouse.



+ Drawing Ellipses
Use the circle tool to draw an ellipse. The circle tool draws in a single width---one pixel.

+ To draw an ellipse:
1.From the color palette, select a color for one of the mouse buttons.

2.From the Toolbox, select the circle tool.
3.Drag the mouse on the drawing area, using the button with the assigned color.

Dragging the mouse on a forty-five degree diagonal produces a circle. Any other
direction produces an ellipse.



+ Drawing Rectangles

You can use the rectangle tool to draw a rectangle. The rectangle tool draws in a single
width---one pixel.

+ To draw a rectangle:
1.From the color palette, select a color for one of the mouse buttons.

2.From the Toolbox, select the rectangle tool.
3.Drag the mouse on the drawing area, using the button with the assigned color.

Dragging the mouse on a forty-five degree diagonal produces a square. Any other
direction produces a rectangle.



+ Drawing Shapes
You can draw the following shapes using the tools from the Toolbox:

e Rectangles, both filled and hollow.
e Ellipses, both filled and hollow.

+ To draw a shape:
1.From the color palette, select a color for one of the mouse buttons.

2.From the Toolbox, select the shape tool.
3.Drag the mouse on the drawing area, using the button with the assigned color.
Dragging on a forty-five degree diagonal creates a circle or a square.

+ To fill a shape with a different color or a different kind of color:
1.From the color palette, select a color for one of the mouse buttons.

2.From the Toolbox, select the flood fill tool.
3.Click the mouse on the shape.

+ Use black, white, light gray, and dark gray to create three-dimensional shading effects.
*



+ Changing the Brush Width
The setting for the brush width controls the width of the line created by the brush tool,
used for drawing free-form lines.

+ To change the brush width:
1.From the Options menu, choose Brush Size.

2.Select a brush width.

*e



Brush Size CcTRL+2, 3,4, 0r5



+ Toggling the Grid

*4

In some cases, it is helpful to know exactly where the pixels are located on an image. For
instance, you might need to center an image, or divide it into thirds. To help you with
these tasks, a grid can be displayed over the drawing area.

To toggle the grid:
e From the Options menu, choose Grid.

The grid appears on the drawing area. A check next to the Grid command on the Options
menu indicates the grid is on. To remove the grid, choose Grid again.

Note For some combinations of window size, display resolution, and pixel dimensions,
the Image Editor may not display the grid. For instance, with a small window---
hence, a small drawing area---on a VGA monitor with a 100-by-100 bitmap, the
Image Editor does not display the grid. In this case, the lines of the grid would be
right next to one another, and the drawing area would appear to be solid black.



Toggle Grid CTRL+G



+ Creating a Cursor Hot Spot
Every cursor must have a single pixel designated as the exact location of the cursor. This
location is called the "hot spot." The position of the hot spot on your application
determines what actions are available in the application at that time---the hot spot
position may determine what shape the pointer takes.

+ To mark the hot spot in a cursor:
1.Select the hot spot tool from the Toolbox.

2.Move the tool to the desired location on the cursor image.
3.Click the left mouse button.

The status bar now displays the coordinates of the grid location chosen for the hot spot.

+ Place the cursor hot spot at a location where the eye is drawn naturally to it. A user will be
able to position the cursor more easily and accurately when the hot spot fits in with the
cursor design.

*
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Draws a rectangle
Draws a filled rectangle
Draws a circle or ellipse

Draws a filled circle or
ellipse






+ What is a Cursor?
A cursor---also called a pointer--represents the position of the mouse pointer. The pixel
which indicates the exact location of the mouse pointer is called the hot spot. This location
determines the action which occurs when the user presses a mouse button, for instance.
Often in an application, different cursor shapes appear as the cursor passes from one
screen region to another. These different cursor types graphically indicate that the types
of action available to the user have changed. The drawing tool is an example of a cursor.



+ What is a Bitmap?
Bitmaps are pictures. The exclamation point or question mark in certain Windows
messages, for example, is a bitmap. All the images that you can create with the Image
Editor are bitmaps. However, the function of an image in a program determines whether
the bitmap is a cursor, an icon, or a bitmap resource such as a question mark.

A bitmap describes the color characteristics for every pixel contained in an image. In a
monochrome (two-color) bitmap, each pixel is represented by one bit, with a value of 1 for
white and 0 for black. A color bitmap uses multiple bits to define the color for a single
pixel.



+ What is an Icon?

Icons represent files or windows when they are minimized. You can place the mouse
pointer on an icon and take some action involving that object. For instance, you could
move the icon to another location on the screen by dragging it. Or you could cause some
action to occur by moving an icon from one window to another, such as moving files from
one directory to another in the Windows File Manager. Or you could double-click an icon
representing a window to expand it.



+ What is an .RC Script?
After creating individual resource files for your application's icon, cursor, bitmap, and
dialog resources, you create a resource script file. The resource script file always has
the .RC extension, and it often simply referred to as the .RC file.

The .RC file lists every resource in your application and describes some types of resources
in great detail:

¢ For resources that exist in a separate file, such as icons and cursors, the .RC simply
names the resource ad that file that contains it.

¢ For some types of resources, such as menus, the entire definition of the resource exists
within the .RC file.

You create a resource script file using an ordinary ASCII text editor. The file can contain
resource statements and directives.



+ Key to the Keyboard

Menu

File

Edit

Options

Other

Command

New

Open

Save

Exit

Undo

Copy

Paste

Clear

Grid

Brush Size

Show Color Palette
Show View Window
Show Toolbox
Jump to Color Palette

Jump to View
Window

Jump to Toolbox

Jump to Properties
Bar

Key
Combination
CTRL+N
CTRL+0
CTRL+S

ALT+F4

CTRL+Z
CTRL+C
CTRL+V
CTRL+L
CTRL+G
CTRL+2,3,4,5
CTRL+F7
CTRL+F8
CTRL+F9

F7

F8

F9
F10



+ Key to the File Menu
For help, click a menu command below---or press TAB to move to the field, and then press
ENTER:

L

Open...
Save
Save As...

Load Colors...
Save Colors...
Bestore Default Colors

Exit




The New command initializes the drawing area with a cursor, bitmap, or icon image.



The Open command opens existing .CUR, .BMP, or .ICO files for editing.
Cursors are saved in .CUR files, bitmaps in .BMP files, and icons in .ICO files.



The Save command saves changes to .CUR, .BMP, and .ICO files.
Cursors are saved in .CUR files, bitmaps in .BMP files, and icons in .ICO files.



The Save As command saves changes to cursors, bitmaps, and icons under a new name.
The original file remains unchanged. You can also use Save As to save new files.

Cursors are saved in .CUR files, bitmaps in .BMP files, and icons in .ICO files.



The Load Colors command loads a color palette (.PAL) into the editor.



The Save Colors command saves newly created colors in a .PAL file.



The Restore Default Colors command restores the default colors on the color palette.



The Exit command exits the Image Editor.



+ Key to the Edit Menu
For help, click a menu command below---or press TAB to move to the field, and then press
ENTER:

o

Bestore

Copy
Paste

Clear

New Image...
Select Image...
Delete Image

*



The Undo command restores an image to its state before the last edit.



The Restore command restores an image to its state when initially loaded into the editor
or when last saved.



The Copy command copies an image to the Clipboard.



The Paste command pastes an image from the Clipboard.



The Clear command clears the current image from the drawing area.



The New Image command initializes the drawing area with a new image for a file. You can
have multiple images in .CUR or .ICO files for various display devices---CGA, EGA, VGA,
and so on.

If the file has images for all currently defined device types, this command is dimmed.



The Select Image command selects an image in a file. This command allows you to select
an image---for a particular display device---in a .CUR or .ICO file for editing.



The Delete Image command deletes an image from the file and clears the View Window.



+ Key to the Options Menu

For help, click a menu command below---or press TAB to move to the field, and then press
ENTER:

Options
+ Grid

Brush Size k

+ Show Color Palette
+ Show Yiew Window

+ Show Toolbox
*




The Grid command superimposes a grid over your cursor, bitmap, or icon in the drawing
area.



The Brush Size command allows you to choose the pixel-width of the brush tool: it can
draw images that are two, three, four, or five pixels wide.



The Show Color Palette command toggles the display of the Color Palette on and off.



The View Window command toggles the display of the View Window on and off.



The Show Toolbox command toggles the display of the Toolbox on and off.



+ Key to the Help Menu
For help, click a menu command below---or press TAB to move to the field, and then press
ENTER:

Help
Contents

Search

About...

*



The Contents command opens the Contents screen for the Image Editor help.



The Search command opens the Search dialog box in help on top of the Contents screen.



The About command gives product information, such as version and name.



+ Key to the Properties Bar
The Properties Bar is a graphical area below the menu bar that displays information about

the currently selected image.

For help, click a field in the Properties Bar below---or press TAB to move to the field, and
then press ENTER:

Image: UEA-Hunu Pos: Size: HotSpol:

*
+*



Jump to Properties Bar F10



The Image label identifies the type of image currently in the drawing area---icon, bitmap,
or cursor. The Image field contains the type of device for the image. You can click the
arrow at the end of the field to display a list of images---these images currently exist in
the file. If you select an image from the list, it appears in the drawing area.



The Position field shows the x and y coordinates for the current position of the drawing
tool on the image.



The Size field displays the horizontal and vertical dimensions of the current drag area for
the mouse. The drag area is the area enclosed from the point where you first pressed the
mouse button down to its present location.



The HotSpot field shows the x and y coordinates for the position of a hot spot on a cursor.
The HotSpot field appears only for cursor images.



+ Key to the View Window
The View window displays the image that you are creating. It displays the image in its
actual size with the chosen screen color around the image perimeter. Use the View
window to check the effect of the image against different screen colors.

For how-to help, click the View window below:




Show View Window CTRL+F8

Jump to View Window F8



You can choose screen colors for the View window by using either the mouse or keyboard.

+ To choose a single color for the screen color:
1.Click the desired color on the color palette with the left mouse button.
2.Click the View window.

+ To cycle through the colors:
1.Click the View window.

2.Press the pLUS (+) key on the numeric keypad to display the next color, or press the
MINUS (=) key to display the previous color.

Each subsequent press on the PLUS or MINUS key displays another color.



+ Key to the Toolbox
You select tools for creating images from the Toolbox.

For help, click a tool in the Toolbox below---or press TAB to move to the field, and then
press ENTER:
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Show Toolbox CTRL+F9

Jump to Toolbox  F9



Pencil tool. Draws a free-form line one pixel in width using the current color.



Brush tool. Paints an image with the current drawing width and color.



Pick rectangle tool. Selects a rectangular region in the image.



Line tool. Draws a straight line between selected begin and end points using the current
color.



Filled rectangle tool. Draws a rectangle and fills it with the current color.



Rectangle tool. Draws a hollow rectangle using the current color.



Circle tool. Draws a hollow circle or ellipse using the current color.



Filled circle tool. Draws a circle or ellipse and fills it with the current color.



Flood fill tool. Fills any form with the current color.



Hot spot tool. Creates a "hot spot" in a cursor. A hot spot is the active area of a cursor.



+ Key to the Color Palette
The Color Palette is a window that displays the current color palette and the colors
associated with the mouse buttons. You can move this window anywhere on your display.
From this window, you can also add different colors to the palette, save or load a palette
or restore the default colors to the palette

For help, click a field in the Color Palette below---or press TAB to move to the field, and
then press ENTER:

Sampke Soeen Sold Colors f Ditheed Colors
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Show Color Palette CTRL+F7

Jump to Color Palette F7



Mouse button indicators.

These indicators display the colors associated with the left and and right mouse buttons.

You can associate any of the opaque colors, the screen color or the inverse color with a
mouse button.

The drawing tool that you are currently using creates shapes with the color associated
with the mouse button that you hold down while using the tool. If it is a dithered color, the
filled rectangle, filled ellipse and flood fill tools use the actual color from the palette, as
shown in the bottom part of the mouse button box. The other tools use the color shown in

the top part of the mouse box, which is the solid color nearest to the chosen dithered
color.



Screen and Inverse color boxes (for cursors and icons only):

The top box shows the screen color; the bottom box shows the inverse color.

The initial colors displayed in these boxes are the nearest solid color to the color set for
the Windows background and the inverse of that color, respectively.



The color boxes display the opaque colors for the currently loaded color palette.

The color palette for a two-color (or monochrome) cursor image shows only black, white,
and dithered colors of black and white.



The Edit button allows you to edit the colors on the palette. You can save an edited color

palette with the Save Colors command on the File menu. A color palette file has a .PAL
extension.

The Default button restores an edited color to its default color value.
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